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SOFTWARE PRODUCT : P-Tool 
VERSION : from 1.08STD R1.000 to before 1.24STD R1.000 
See Version Note below. 
CLASSIFICATION : Installation / Operation 

 

P-Tool private characters installation procedure 

This document describes how to install private character files used to display “package polarity” icons 
used in the P-Tool Visual Editor. 

Version Note 

From version 1.24STD R1.000, setup.exe file for installing private characters to P-Tool is provided in 
the P-Tool installation CD. If you use the setup.exe file, you don’t have to perform the installation 
procedure herein. The setup.exe file is also available for earlier versions than 1.24STD R1.000. 

Warnings 

• This document is designed for customers who intend to learn the use of P-Tool. 

• Make sure to use this document under the instruction of those who completed the maintenance 
training or YAMAHA service personnel. 

• YAMAHA is not responsible for any problems caused by the misuse of the document. 

• Make sure to thoroughly understand the contents of the document, and follow the instructions on 
your own responsibility. 

 

Disclaimers 

This document contains information that might change in the future. 

The information herein represents the current view of YAMAHA on the issues discussed as of the 
date of issuance. As YAMAHA must respond to changing market conditions, it should not be 
interpreted to be a commitment on the part of YAMAHA, and YAMAHA cannot guarantee the 
accuracy of any information presented after the date of issuance. 

This document is provided for information purposes only, and it is provided without any warranties, 
either express or implied. 

It is the responsibility of the user to comply with all applicable copyright laws. Without limiting the 
rights under copyright, no part of this document may be reproduced, stored in or introduced into a 
retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, 
recording, or otherwise), or for any purpose, without the written permission of YAMAHA. 

However, this shall not be construed to limit the user’s right granted by Copyright law.  

YAMAHA may have patents, patent applications, trademarks, copyrights, or other intellectual property 
rights covering subject matter in this document. Except as expressly provided in any written license 
agreement from YAMAHA, this document does not give users any license to these patents, 
trademarks, copyrights, or other intellectual property. 

The names of actual companies and products mentioned herein may contain the trademarks of their 
respective owners. 

No: SI0909003E-001
ISSUED DATE: 16 December 2010
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1 Required items 

Prepare the following items: 

• P-Tool installation CD (contains private character files for the Visual Editor) 

• If your P-Tool runs on an English version Windows XP computer, prepare the Windows XP 
installation CD. 

2 Before installing the private character files 

2.1 Required conditions 

• You logged on to the Windows computer with an Administrative account. 

• The P-Tool installation CD is at your disposal. 
The required font files “EUDC.EUF” and “EUDC.TTE” are located in 
“\Support\VisualEditor\EUDC” of the installation CD. 

• You started your computer but are yet to start the private character editor nor any 
application that uses private characters. If you have started any of them, restart your 
computer. 

• If you have registered your own private characters, you need to back up the existing private 
character files beforehand as described later on. Otherwise, you cannot restore your private 
characters afterward. The private characters used for the Visual Editor are to be assigned to 
E000 through E19F of the Unicode Standard (Unicode is a worldwide character-encoding 
standard.). Thus you are to re-assign your existing characters to other than those codes. 
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2.2 Create a desktop shortcut to the private character editor 

You need to open the private character editor to check the status of your private character 
registration. If the [Private character editor] program is not found in the Start menus ([Start] > 
[Programs] > [Accessories]), create a desktop shortcut as follows: 

Step 1 Open the Folder Options dialog box in either way: 

• Open an Windows Explorer window. Click [Tools] > [Folder Options]. 

• From [Control Panel], select [Folder Options]. 

Step 2 In the Folder Options dialog box, open the [View] tab. 

Step 3 Under [Advanced settings], uncheck “Hide extensions for known file types”. 

Step 4 Click the [Apply to All Folders] button (the actual button name might differ) above 

[Advanced settings]. Then click the [OK] button. 

Step 5 In an Explorer window, display “c:\Windows\system32”  

Step 6 Under “system32”, right-click “eudcedit.exe” to display its drop-down menu. Select 

[Send To] > [Desktop (create shortcut)]. 

Step 7 Rename the created desktop shortcut “PrivateCharacterEditor”. 
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2.3 Check the registration status of the Private Character Editor 

Step 1 Start the Private Character Editor. 
From the [Start] menu at the lower left corner of the screen, select [Programs] > 
[Accessories] > [Private Character Editor]. If you created a desktop shortcut in “2.2 Create 
a desktop shortcut to the private character editor” on page 3, you can also start the Private 
Character Editor by double-clicking the icon. 

 

Step 2 Click the [Cancel] button to close the Select Code dialog box. 

Step 3 Check that [Character Set] at the upper left part of Private Character Editor is set to 

“Unicode”. If not, select “Unicode” from the drop-down list of [Character Set]. 

 

Step 4 Select [Edit] > [Select Code] from the menu bar. The Select Code dialog box 

reappears. 

 

 

 

Currently selected character 
code appears here. 

 
 
 
When the starting character 
code is “E000”, it means 
[Character Set] is set to  
“Unicode”. 
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Step 5 When private characters for P-Tool are registered, the screen should look like below: 

 

Note 
To scroll up and down the characters list, use the scroll bar and do not use your mouse’s 
scroll wheel. Use of the scroll wheel will disable the scroll bar. If the scroll bar is disabled, 
click the [Cancel] button to close the dialog box and reopen by selecting [Edit] > [Select 
Code]. 

Step 6 Check the code of registered private characters. 
If you have private characters registered in the editor, record their codes for later 
re-registration. If your private characters have been assigned to code E000-E19F which are 
to be used for P-Tool, you need to reregister those characters at other than E000-E19F. 

Step 7 Restart the computer. 

Tip 
When you start the Private Character Editor, “EUDC.TTE” becomes busy and you may not 
be able to delete or copy “EUDC.TTE” in the later procedure. Therefore you need to restart 
the computer. 

 

 

Make sure that “Unicode” 
is selected. 

Use the scroll bar to 
check all registered 
characters. 

If no character is registered, either of: 

   will be displayed. 
When a character e.g. “   ”is registered: 

 will be displayed. 
 
Clicking [OK] will show its editing window. 
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2.4 Back up the private character files with Windows Explorer 

When you copy the private character files to your computer, existing private characters in your 
computer might be lost. To be prepared for this, back up the existing private character files. If no 
private characters are registered in your computer or you don’t use them at all, backup 
procedure is not necessary. 

Step 1 From the [Start] menu, select [Search] > [For Files or Folders]. 
In some operation systems, the Search application can be accessed directly from the [Start] 
menu. 

Step 2 Enter “EUDC.*” in the [All or part of the file name] field. Then click the [Search] button. 

Step 3 “EUDC.EUF” and “EUDC.TTE” are located in C:\WINDOWS\Fonts. 

 

Note 
“EUDC.EUF” and “EUDC.TTE” files may not exist in some computers where the files have 
been deleted or no private characters have been registered. If this is the case the backup 
procedure is unnecessary. 

Step 4 Copy “EUDC.EUF” and “EUDC.TTE” to another folder as backup files. 

Step 5 Restart the computer. 

Note 
If you cannot back up the private character files using Windows Explorer, use Command 
Prompt as shown in the following section. 
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2.5 Back up the private character files using Command Prompt 

Use the procedure below when you cannot back up the private character files with Windows 
Explorer as described in “2.4 Back up the private character files with Windows Explorer” on page 
6. 

Step 1 Create a folder in drive C and name the folder with one-byte alphanumerals. 

 

Step 2 Click the [Start] menu at the lower left corner of the screen. 

Step 3 Select [Programs] > [Accessories] > [Command Prompt]. 
If [Command Prompt] is not found, select [Start] > [Run], then enter “cmd” in the provided 
field. The Command Prompt will start. 

Step 4 Type in at the cursor as follows to execute copying: 

copyc:\Windows\Fonts\EUDC.*c:\b\ 

Note5 

• “b”: Enter the folder name specified in step 1 above (“b” is an example). 

• “*”: Enter an asterisk (*). 

• “”: Enter a space. 

 

Step 5 The following text lines appear to indicate that two files have been copied. 

 

Step 6 Restart the computer. 

 

In drive C create a folder and name it 
with one-byte alphanumerals. 
 

b 
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2.6 Delete the existing private character files 

Before copying the private character files to the computer, you need to once delete the existing 
private character files in the computer. Otherwise, overwriting or copying process may fail. 

Step 1 From the [Start] menu, select [Search] > [For Files or Folders]. 
In some operation systems, the Search application can be accessed directly from the [Start] 
menu. 

Step 2 Enter “EUDC.*” in the [All or part of the file name] field. Then click the [Search] button. 

Step 3 “EUDC.EUF” and “EUDC.TTE” are located in C:\WINDOWS\Fonts. 

 

Step 4 Delete only “EUDC.EUF” and “EUDC.TTE” under C:\WINDOWS\Fonts. 

Step 5 If you cannot delete “EUDC.EUF” and/or “EUDC.TTE” with such an error message as 

the file is in use, rename the file(s) in the above Search Results window. You may still 

not be able to delete the file(s) after renaming, but you don’t have to delete them. After 

you copy private character files to the computer, you can delete the renamed file(s). 

 

Step 6 Restart the computer. 

 

 

 

 

 

 

_a 

_a 
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2.7 Check if the private character files have been deleted successfully 

The private character files are not displayed in a Windows Explorer window. Use the Command 
Prompt window to check if the private character files have been deleted successfully. 

Notes 

• Do not start the private character editor when no private character file exists in the 
computer. Otherwise the private character editor may not be able to start and/or a new 
private character file may be created. 

• Unless existing private character files in the computer are deleted, the private character 
files in the CD may not be installed to the computer properly. 

Step 1 Click the [Start] menu at the lower left corner of the screen. 

Step 2 Select [Programs] > [Accessories] > [Command Prompt]. 
If [Command Prompt] is not found, select [Start] > [Run], then enter “cmd” in the provided 
field. The Command Prompt will start. 

Step 3 Type in at the cursor as follows so the contents of “c:\Windows\Fonts” are listed: 

dirc:\Windows\Fonts 

Note 

“” indicates a space. 

 

Step 4 The listed files are in alphabetical order. Use the scroll bar on the right of the window 

to check that “EUDC.EUF” and “EUDC.TTE” have been deleted. 

 

 

 

 

 

Check file names starting with “e” and make sure 
“EUDC.EUF” and “EUDC.TTE” are not listed. 
 

“EUDC.TTE” has been renamed “EUDC.TTE_a”. You can 
either delete “EUDC.TTE” or just leave it. 
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3 Install the private character files 

Copy the private character files from the P-Tool installation CD (\Support\VisualEditor\EUDC) to 
the computer. 

You cannot copy “EUDC.EUF” and “EUDC.TTE” to the computer using Windows’ normal copy 
and paste operation. You must use Command Prompt instead. 

Step 1 Click the [Start] menu at the lower left corner of the screen. 

Step 2 Select [Programs] > [Accessories] > [Command Prompt]. 
If [Command Prompt] is not found, select [Start] > [Run], then enter “cmd” in the provided 
field. The Command Prompt will start. 

Step 3 Type in at the cursor as follows to execute copying: 

copy(network path to the files to be copied)\EUDC.*c:\Windows\Fonts 

Note 

• “*”: Enter an asterisk (*). 

• “”: Enter a space. 

 

Step 4 The following text lines appear to indicate that two files have been copied. 

 

Step 5 Restart the computer. 
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4 Procedure after installing the private character files 

4.1 Install East Asian languages (only for Windows XP English version) 

In use of Windows XP English version, to enable the private characters to be displayed properly, 
you may need to change Windows’ language setting. To change the setting, the Windows XP 
installation CD may be required. 

Step 1 Open [Control Panel]. 

Step 2 Double-click [Date, Time, Language, and Regional Options]. If this icon is not shown, 

proceed to step 3. 

Step 3 Double-click [Regional and Language Options] to open its dialog box. 

Step 4 Click the “Languages” tab. 

Step 5 Tick “Install files for East Asian languages”. 

 

Step 6 Install East Asian language files including Chinese, Japanese, and Korean to the 

computer. The computer may prompt you to insert the Windows XP installation CD in 

the CD drive. In this case, follow the instruction. Click [OK] or [Apply] to execute 

installation. 

Step 7 Restart the computer. 
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4.2 Link the private character files with your font library 

Link the copied private character files with your font library. Also check that the private characters 
have been registered properly using the private character editor. 

Step 1 Start the private character editor. 

Step 2 The Select Code dialog box appears. Click the [Cancel] button to close the dialog box. 

Step 3 Select “Unicode” from the drop-down list of [Character Set]. 

 

 

Step 4 Select [File] > [Font Links] to open the Font Links dialog box.  

 

Step 5 Under [Type of private Character font], select “Link with All Fonts”. Click the [OK] 

button. 

Step 6 Select [Edit] > [Select Code] to open the Select Code dialog box. 

Step 7 Make sure that private characters you copied appear in the dialog box from “E000”. 

4.3 If you fail to copy the private character files… 

If no component package icons but instead “•”, “ ” or spaces are shown in the P-Tool Visual 
Editor and/or the private character editor, you may have failed in copying the private character 
files. In this case start over from “2.6 Delete the existing private character files” on page 8. 

4.4 Reregister the backed up private characters 

Where appropriate reregister the backed up private characters to other codes than “E000-E19F” 
using the private character editor. 

 
 
 


